iOS

Mac OS X 10.11升级带来的 cocoapods问题

cocoapods

Posted by CatchZeng on October 25, 2015

前言

昨天升级完Mac OS X 10.11,发现cocoapods不能用了。 后面用以下命令解决了,在此记录希望能帮到需要的朋友。 如在执行以下命令时出现问题,请看更新部分

sudo chmod -R 755 /usr/local/bin
sudo gem uninstall cocoapods
sudo gem install -n /usr/local/bin cocoapods
sudo xcode-select -switch /Applications/Xcode.app/

更新

昨天又升级了一下自己的笔记本,发现了其他问题,整理如下。

1.执行sudo chmod -R 755 /usr/local/bin时出现没有该路径的问题 这里写图片描述 解决办法:在/usr/local/ 创建bin文件夹 这里写图片描述

2.执行gem install -n /usr/local/bin cocoapods时出现以下错误 这里写图片描述 解决办法: 添加http://rubygems.org/源地址

gem sources -a http://rubygems.org/

3.再次执行gem install -n /usr/local/bin cocoapods,出现权限问题 解决办法:赋予权限

sudo chmod -R 777 /Library/Ruby/Gems/2.0.0/
sudo chmod -R 777 /usr/local/bin/

4.继续执行gem install -n /usr/local/bin cocoapods,安装成功! 这里写图片描述

5.pod –version 检验,出现warning信息 这里写图片描述 解决办法: 此warning是因为我们刚才的权限赋值777的问题,完成安装后赋回755可去除warning。 这里写图片描述

这里写图片描述